算法题 Crashing Balloon

Crashing Balloon from ZOJ(浙大OJ) Problem Set - 1003,链接http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3

题目如下:

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV. The rule is very simple. On the ground there are 100 labeled balloons, with the numbers 1 to 100. After the referee shouts "Let's go!" the two players, who each starts with a score of "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash. After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numbers on the balloons he\she's crashed. The unofficial winner is the player who announced the highest score.

Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved. The player who claims the lower score is entitled to challenge his\her opponent's score. The player with the lower score is presumed to have told the truth, because if he\she were to lie about his\her score, he\she would surely come up with a bigger better lie. The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player. So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49. Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculations that refereeing requires. Hence the need for you, sober programmer, to provide a software solution.
Input
Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon.
Output
Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome.

Sample Input
343 49
3599 610
62 36

Sample Output
49
610
62

第一次看这题的时候仅仅是用简单的循环来做的,就是把所有因子的情况都计算保存起来,虽然实现了,但是打的补丁众多,而且易读性极差,最重要的是不能过提交。然后看了网上的一篇教程:Leo.cheng 的 【Acm】算法之美—Crashing Balloon https://www.cnblogs.com/lcw/p/3159413.html,才发现原来可以用深度优先遍历来做。

刚开始看这位大佬的算法是比较迷糊的,毕竟算法是一种思想,需要理解,接下来我简单说明一下这位算法大佬的思路:用深度优先遍历来做,每层遍历表示一个可以因子,最终目的就是为了试完所有因子的组合。

代码我用大佬的思想重新写了一遍,我比较喜欢这种风格:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

// 运用了深度优先 的搜索策略
// 不同的深度表示不同的因子
void dfs(int *global_max,int *global_min,int max,int min,int divisor)
{
    /********** **********/
    // 表示因子够min分配的情况下,max因子也够分配
    if(max==1 && min==1) // 在两个数的所有各不相同的因子中,有因子能重新乘出给出的两个数,则max说了真话
    {
        *global_max = 1; // max说了真话
        return;
    }

    // 表示因子够min分配
    if(min==1)  // 在两个数的所有各不相同的因子中,没有任何因子能重新乘出给出的两个数,则min说了真话
    {           // 也就是因子仅仅够min分配,而不够max分配
        *global_min = 1;
    }

    /********** **********/
    while(divisor < 100 &&  // 大于100了就不符合题目
            (divisor < max || divisor < min)) // 同时大于max与min就没有了意义
    {
        divisor++;

        if(min % divisor == 0)
        {
            dfs(global_max, global_min, max, min/divisor, divisor);
            if(*global_max == 1)
            {
                return;
            }
        }

        if(max % divisor == 0)
        {
            dfs(global_max, global_min, max/divisor, min, divisor);
            if(*global_max == 1)
            {
                return;
            }
        }
    }
}

int main()
{
    int max,min,temp,global_max,global_min;
    while((scanf("%d %d",&max,&min))!=EOF)
    {
        global_max = 0;
        global_min = 0;
        if(max < min)
        {
            temp = max;
            max = min;
            min = temp;
        }

        dfs(&global_max, &global_min, max, min, 1);

        // 表示因子够min分配的所有情况中max的因子不够分配
        if(global_max == 0 && global_min == 1)
        {
            printf("%d\n",min);
        }
        else
        {
            printf("%d\n",max);
        }
    }

    return 0;
}